How to fix a broken photo gallery and lightbox after WooCommerce 3.0 upgrade – Create and Code


If you’re experiencing a broken photo gallery and your lightbox has gone missing after upgrading to WooCommerce 3.0 you’re not alone. Read on to find out how to fix it. Help my WooCommerce lightbox is no longer working!
Prior to upgrading to WooCommerce 3.0, you used to have an option in WooCommerce -> Settings -> Products -> Display that looked like this.
With that feature enabled, it would deliver an experience like this.
So let’s assume for a moment that you don’t follow the WooCommerce development blog (you should!) and let’s assume you didn’t test WooCommerce 3.0 on your staging website first (because what kind of animal doesn’t always test plugin updates on a staging version first? Hint – most people).
Everything has been working fine on your site and then you went ahead and updated to WooCommerce 3.0 on your live WooCommerce website.
(SIDENOTE: Never simply update a live website to use a new version of WooCommerce – ever! Always, always, always update a development/staging copy of your website first and thoroughly test everything to make sure there are no unexpected side effects. If you need a good quality host that
Source: https://managewp.org/articles/14782/how-to-fix-a-broken-photo-gallery-and-lightbox-after-woocommerce-3-0-upgrade-create-and-code


Source: https://williechiu40.wordpress.com/2017/04/06/how-to-fix-a-broken-photo-gallery-and-lightbox-after-woocommerce-3-0-upgrade-create-and-code/

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s